RICADO - 0800 Calls is back up – Incident details
Email Support
Documentation
Get updates
Email
Slack
Email Support
Documentation
Get updates
All systems operational
0800 Calls is back up
Resolved
Major outage
Started 11 days ago
Lasted 10 minutes
Affected
Support
Operational from 7:44 AM to 7:44 AM, Major outage from 7:44 AM to 7:54 AM
0800 Calls
Operational from 7:44 AM to 7:44 AM, Major outage from 7:44 AM to 7:54 AM
Updates
Resolved
April 03, 2026 at 7:54 AM
Resolved
April 03, 2026 at 7:54 AM
0800 Calls are back up.
Investigating
April 03, 2026 at 7:44 AM
Investigating
April 03, 2026 at 7:44 AM
0800 Calls are down at the moment.