RICADO - 0800 Calls is back up – Incident details
Email Support
Documentation
Get updates
Email
Slack
Email Support
Documentation
Get updates
All systems operational
0800 Calls is back up
Resolved
Major outage
Started 10 days ago
Lasted 8 minutes
Affected
Support
Operational from 2:50 AM to 2:50 AM, Major outage from 2:50 AM to 2:58 AM
0800 Calls
Operational from 2:50 AM to 2:50 AM, Major outage from 2:50 AM to 2:58 AM
Updates
Resolved
May 03, 2026 at 2:58 AM
Resolved
May 03, 2026 at 2:58 AM
0800 Calls are back up.
Investigating
May 03, 2026 at 2:50 AM
Investigating
May 03, 2026 at 2:50 AM
0800 Calls are down at the moment.